RemoveRule Method


Routing Preference Manager Remove Rule Method

Removes an existing routing preference rule. Thrown if the index is out of bounds.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void RemoveRule(
	RoutingPreferenceRuleGroupType groupType,
	int index
)

Parameters

groupType RoutingPreferenceRuleGroupType
The routing preference group type in which the rule should be removed.
index Int32
The index position of removed routing preference rule in the group.
Exceptions
Exception Condition
ArgumentException index is not a valid zero-based index within groupType. -or-
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also