NewFlexDuct Method (IList(XYZ), FlexDuctType)


Document New Flex Duct(IList XYZ , Flex Duct Type) Method

Adds a new flexible duct into the document, using a point array and duct type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public FlexDuct NewFlexDuct(
	IList<XYZ> points,
	FlexDuctType ductType
)

Parameters

points IList XYZ
The point array indicating the path of the flexible duct, including the end points.
ductType FlexDuctType
The type of the flexible duct.

Return Value

FlexDuct
If creation was successful then a new flexible duct is returned, otherwise an exception with failure information will be thrown.
Exceptions
Exception Condition
ArgumentNullException Thrown when the input argument points is .
InvalidOperationException Thrown when the flexible duct cannot be created or regenerate fails.
ArgumentException Thrown if the flexible duct type does not exist in the given document.
See Also