FormattedText Constructor (String)


Formatted Text(String) Constructor

Creates a new FormattedText object with unformatted text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public FormattedText(
	string plainText
)

Parameters

plainText String
The text in a plain text form.
Exceptions
Exception Condition
ArgumentException plainText (excluding a carriage return character ('\r') at the end) has more than 30,000 characters. -or- plainText contains invalid characters such as a newline character.
ArgumentNullException A non-optional argument was null
Remarks
The given text should have no more than 30,000 characters. Line feed characters ('/n') are not allowed. An empty string is allowed.
Example
public void ReformatText(TextNote textNote, string textToChange)
{
    String plainText = textNote.Text;
    FormattedText formattedText = new FormattedText(plainText);

    TextRange foundRange = formattedText.Find(textToChange, 0, false, true);
    while (foundRange.Length > 0)
    {
        formattedText.SetBoldStatus(foundRange, true);
        foundRange = formattedText.Find(textToChange, foundRange.End, false, true);
    }

    textNote.SetFormattedText(formattedText);
}
See Also