SetExecutionOrder Method


Updater Registry Set Execution Order Method

Forces execution order between two updaters Execution order: first before second

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static void SetExecutionOrder(
	UpdaterId first,
	UpdaterId second
)

Parameters

first UpdaterId
Id of first Updater
second UpdaterId
Id of second Updater
Exceptions
Exception Condition
ArgumentException One or both inputs are not valid UpdaterIds -or- One or both of the Updaters are not registered -or- first and second are the same id
ArgumentNullException A non-optional argument was null
ArgumentsInconsistentException The updaters do not report the same ChangePriority
See Also