IsRodLockedWithHost Method


Fabrication Rod Info Is Rod Locked With Host Method

Checks if the rod is locked with the host. The method is applicable only for bearer hanger.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsRodLockedWithHost(
	int rodIndex
)

Parameters

rodIndex Int32
The index of the rod.

Return Value

Boolean
True if the rod is locked with its host.
Exceptions
Exception Condition
ArgumentOutOfRangeException the index rodIndex is should be in range of rod count.
InvalidOperationException The hanger is not a bearer hanger.
See Also