ViewDisplayBackground Class


View Display Background Class

Set of values that control how background is drawn in a view. Background can only be set for a 3d view or for a section or elevation view.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ViewDisplayBackground

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ViewDisplayBackground : IDisposable

The ViewDisplayBackground type exposes the following members.

Properties
Name Description
Public property BackgroundColor The color of the horizon when the type is 'Gradient'.
Public property GroundColor The color of the ground when the type is 'Gradient' or 'SunAndClouds'.
Public property HorizontalImageOffset The distance between the left viewport boundary and the left edge of the background image.
Public property HorizontalImageScale The horizontal scale of the background image; the scale of 1.0 puts the image pixel-to-pixel.
Public property ImageFlags The image alignment indicators when the type is 'Image'.
Public property ImagePath The path to the image file when the type is 'Image'.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property SkyColor The color of the sky when the type is 'Gradient'.
Public property Type The type of the background.
Public property VerticalImageOffset The distance between the bottom viewport boundary and the bottom edge of the background image.
Public property VerticalImageScale The vertical scale of the background image; the scale of 1.0 puts the image pixel-to-pixel.
Top
Methods
Name Description
Public method Static member CreateGradient Creates an object that can be passed to View.SetBackground method to set the background of the Gradient type.
Public method Static member CreateImage Creates an object that can be passed to View.SetBackground method to set the background of the Image type.
Public method Static member CreateSky Creates an object that can be passed to View.SetBackground method to set the background of the SunAndClouds type.
Public method Dispose Releases all resources used by the ViewDisplayBackground
Top
See Also