Direct |
Validates shape to be stored in a DirectShapeType.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- shape IList GeometryObject
- Shape to be validated represented as a collection of GeometryObjects. The supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point, Curve and PolyLine.
Return Value
BooleanTrue if the supplied shape passes the validation criteria.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

This function calls IsValidShape(GeometryObject) to validate each object in the list.