YoungModulus Property


Structural Asset Young Modulus Property

The Young's modulus of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public XYZ YoungModulus { get; set; }

Property Value

XYZ
Exceptions
Exception Condition
ArgumentNullException When setting this property: A non-optional argument was null
InapplicableDataException When setting this property: the material type is wood. -or- When setting this property: the behavior is isotropic.
Remarks
This property cannot be used to set the Young's modulus for wood-based and isotropic materials. For such assets, use setYoungModulus instead. The value is in Newtons per foot meter (N/(ft · m)).
See Also