BuiltInFailures.PartMakerMethodForMergePartFailures Class


Built In Failures Part Maker Method For Merge Part Failures Class

Failures related to part merge operations.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BuiltInFailures PartMakerMethodForMergePartFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class PartMakerMethodForMergePartFailures

The BuiltInFailures PartMakerMethodForMergePartFailures type exposes the following members.

Properties
Name Description
Public property Static member MergedPartHasDisConnectedGeometries A merged part geometry has dis-connected components.
Public property Static member NeedTwoPartsToMerge Attempt to merge fewer than two parts. There must be at least two. No part will be produced.
Public property Static member PartNotIncludedInMerge This part is not geometrically coincident with another part of the same material. No merge possible.
Public property Static member PartsCannotBeMerged This PartMaker refers to parts which cannot be merged.
Public property Static member UnableToIncludePartInMerge Attempt to merge this Part results in failure of boolean operation. Cannot compute combined geometry.
Top
See Also