Workset |
WorksetId identifies a workset within a single document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The WorksetId type exposes the following members.


Name | Description | |
---|---|---|
![]() | IntegerValue | Provides the value of the WorksetId as an integer. |
![]() ![]() | InvalidWorksetId | Get the invalid WorksetId whose IntegerValue is -1. |

Name | Description | |
---|---|---|
![]() | Compare | Compares two WorksetIds. |
![]() | Equals | Determines whether the specified Object is equal to the current Object . (Overrides Object Equals(Object) ) |
![]() | GetHashCode | Gets the integer value of the id as hash code (Overrides Object GetHashCode ) |
![]() | ToString | Gets a String representation of the integer value of the id. (Overrides Object ToString ) |

Name | Description | |
---|---|---|
![]() ![]() | Equality(WorksetId, WorksetId) | Determines whether these two WorksetIds are the same. |
![]() ![]() | GreaterThan(WorksetId, WorksetId) | Determines whether one WorksetId is greater than another WorksetId. |
![]() ![]() | GreaterThanOrEqual(WorksetId, WorksetId) | Determines whether one WorksetId is not less than another WorksetId. |
![]() ![]() | Inequality(WorksetId, WorksetId) | Determines whether these two WorksetIds are different. |
![]() ![]() | LessThan(WorksetId, WorksetId) | Determines whether this WorksetId is less than another WorksetId. |
![]() ![]() | LessThanOrEqual(WorksetId, WorksetId) | Determines whether one WorksetId is not greater than another WorksetId. |

WorksetId is not guaranteed to be unique. It is only valid within one model and its value may change when the model is synchronized with central. If unique identification of a workset is needed, the workset's GUID should be used instead.