IPerformance |
Base class to derive specific performance adviser rules from.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The IPerformanceAdviserRule type exposes the following members.

Name | Description | |
---|---|---|
![]() | ExecuteElementCheck | Invoked by performance advisor for each element to be checked. |
![]() | FinalizeCheck | Invoked by performance advisor once in the end of the check. |
![]() | GetDescription | Retrieves the description of the rule. |
![]() | GetElementFilter | Retrieves a filter to restrict elements to be checked. |
![]() | GetName | Retrieves the name of the rule. |
![]() | InitCheck | Invoked by performance advisor once in the beginning of the check. If rule checks document as a whole, the check can be performed in this method. |
![]() | WillCheckElements | Reports if rule needs to be executed on individual elements. |