FormatValueOptions Class


Format Value Options Class

Options for formatting numbers with units into strings.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB FormatValueOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FormatValueOptions : IDisposable

The FormatValueOptions type exposes the following members.

Constructors
Name Description
Public method FormatValueOptions Creates a new FormatValueOptions object with default settings.
Top
Properties
Name Description
Public property AppendUnitSymbol Indicates if a unit symbol should be appended regardless of the settings in the FormatOptions.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the FormatValueOptions
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetFormatOptions Gets the FormatOptions to optionally override the default settings in the Units class.
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method SetFormatOptions Sets the FormatOptions to optionally override the default settings in the Units class.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also