Point Property


Location Point Point Property

The physical location of the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public XYZ Point { get; set; }

Property Value

XYZ
Remarks
Setting this property is not supported for some elements supporting LocationPoints, such as SpotDimensions.
Example
void LocationMove(FamilyInstance column)
{
    LocationPoint columnPoint = column.Location as LocationPoint;
    if (null != columnPoint)
    {
        XYZ newLocation = new XYZ(10, 20, 0);
        // Move the column to the new location
        columnPoint.Point = newLocation;
    }
}
See Also