ElementOwnerViewFilter Constructor (ElementId, Boolean)


Element Owner View Filter(Element Id, Boolean) Constructor

Constructs a new instance of a filter to match elements which are owned by a particular view, with the option to invert the filter and find elements not owned by the given view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementOwnerViewFilter(
	ElementId viewId,
	bool inverted
)

Parameters

viewId ElementId
The view id to match. Pass invalid element id to create a filter that will pass non-view-specific elements.
inverted Boolean
True if the filter should match all elements which are not owned by the given view.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also