Direct |
Builds the type shape from the supplied collection of GeometryObjects. The objects are copied. If the new shape is identical to the old one, the old shape will be kept.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public void SetShape(
IList<GeometryObject> pGeomArr,
DirectShapeTargetViewType viewType
)
Parameters
- pGeomArr IList GeometryObject
- Shape of this object expressed as a collection of GeometryObjects. These will be copied. Shape and Category should be consistent: geometry supplied as shape should be valid for the Category the type object is associated with. For viewType = DirectShapeTargetViewType::Default, the supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point and Curve. For viewType = DirectShapeTargetViewType::Plan, the supported types of GeometryObjects are: Point and Curve
- viewType DirectShapeTargetViewType
- Specifies which target view type to associate the geometry with. The target view type will decide which views can show this geometry.

Exception | Condition |
---|---|
ArgumentException | At least one member of pGeomArr does not satisfy DirectShapeType validation criteria. |
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |