ReferenceIntersector Constructor (ElementFilter, FindReferenceTarget, View3D)


Reference Intersector(Element Filter, Find Reference Target, View 3D) Constructor

Constructs a ReferenceIntersector which is set to return intersections from any element which passes an input filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ReferenceIntersector(
	ElementFilter filter,
	FindReferenceTarget targetType,
	View3D view3d
)

Parameters

filter ElementFilter
The element filter. All references will belong to elements passing this filter.
targetType FindReferenceTarget
The target type of references to return.
view3d View3D
The view in which to find references.
Exceptions
Exception Condition
ArgumentException Returns true if the view is not a view template.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also