RebarShapeSegmentEndReferenceType Enumeration


Rebar Shape Segment End Reference Type Enumeration

A choice of two reference points for one end of a constraint driving the length of a RebarShapeSegment.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public enum RebarShapeSegmentEndReferenceType
Members
Member name Value Description
Straight 0 Refers to the end of the straight part of the segment: the point where the bend begins.
Exterior 1 Refers to the farthest point on the arc of the bend. Assuming the bend is 90 degrees or more, an Exterior constraint will be longer than a Straight constraint by an amount equal to the bend radius.
Remarks
The RebarShapeSegmentEndReferenceType of a constraint is meaningful only when the bend is right or obtuse . If the bend is acute , the reference type is ignored.
See Also