AnalysisDisplayColorSettings Class


Analysis Display Color Settings Class

Contains color settings for analysis display style element.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Analysis AnalysisDisplayColorSettings

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class AnalysisDisplayColorSettings : IDisposable

The AnalysisDisplayColorSettings type exposes the following members.

Constructors
Name Description
Public method AnalysisDisplayColorSettings Constructs a default instance of color settings.
Public method AnalysisDisplayColorSettings(AnalysisDisplayColorSettings) Constructs a new copy of the input AnalysisDisplayColorSettings object.
Top
Properties
Name Description
Public property ColorSettingsType Stores type of color settings
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property MaxColor Color assigned to the maximum value.
Public property MinColor Color assigned to the minimum value.
Top
Methods
Name Description
Public method AreIntermediateColorsValid Verify intermediate color entries
Public method Colors Get number of colors, including min, max and intermediate.
Public method Dispose Releases all resources used by the AnalysisDisplayColorSettings
Public method GetIntermediateColors Get intermediate color entries (other than the minimum and maximum settings).
Public method IsEqual Compares two color settings objects.
Public method SetIntermediateColors Set intermediate color entries (other than the minimum and maximum settings).
Top
Example
AnalysisDisplayColorSettings colorSettings = new AnalysisDisplayColorSettings();
Color orange = new Color(255, 205, 0);
Color purple = new Color(200, 0, 200);
colorSettings.MaxColor = orange;
colorSettings.MinColor = purple;
See Also