Revit |
Gets the id of this link's immediate parent.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Return Value
ElementIdThe id of the immediate parent of this link, or invalidElementId if this link is a top-level link.

This function returns the immediate parent id. Given the link structure A -> B -> C, then calling this function on C will return B's id. Call GetRootId to get A's id.