StructuralFramingUtils Class


Structural Framing Utils Class

A collection of Structural Framing Utilities.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure StructuralFramingUtils

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class StructuralFramingUtils

The StructuralFramingUtils type exposes the following members.

Methods
Name Description
Public method Static member AllowJoinAtEnd Sets the indicated end of the framing element to be allowed to join to others.
Public method Static member CanFlipEnds Determines if the ends of the given framing element can be flipped.
Public method Static member CanSetEndReference Determines if a reference can be set for the given end of the framing element.
Public method Static member DisallowJoinAtEnd Sets the indicated end of the framing element to not be allowed to join to others.
Public method Static member FlipEnds Flips the ends of the structural framing element.
Public method Static member GetEndReference Returns a reference to the end of a framing element according to the setback settings.
Public method Static member IsEndReferenceValid Determines if the given reference can be set for the given end of the framing element.
Public method Static member IsJoinAllowedAtEnd Identifies if the indicated end of the framing element is allowed to join to others.
Public method Static member RemoveEndReference Resets the end reference of the structural framing element.
Public method Static member SetEndReference Sets the end reference of a framing element.
Top
See Also