ExternalResourceBrowserData Class


External Resource Browser Data Class

Represents a collection of external resources and external resource folders to be presented as the content of a folder in the file browser in Revit.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ExternalResourceBrowserData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ExternalResourceBrowserData : IDisposable

The ExternalResourceBrowserData type exposes the following members.

Constructors
Name Description
Public method ExternalResourceBrowserData Constructs a new ExternalResourceBrowserData using the given document(optional), server id, folder path and match options.
Top
Properties
Name Description
Public property FolderPath The current folder path to which the new resources and subfolder belong.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property ServerId The Id of IExternalResourceServer which handles the external resource load.
Top
Methods
Name Description
Public method AddResource(String) Adds an external resource to the folder path by supplying the resource name.
Public method AddResource(String, IDictionary String, String ) Adds an external resource to the folder path by supplying the resource name and reference information.
Public method AddResource(String, String) Adds an external resource to the folder path by supplying the resource name and version.
Public method AddResource(String, String, IDictionary String, String ) Adds an external resource to the folder path by supplying the resource name, version and reference information.
Public method AddSubFolder(String) Adds a subfolder to the folder path with the given name.
Public method AddSubFolder(String, String) Adds a subfolder to the folder path with the given name and icon type.
Public method CallingDocumentHasModelPath Indicates whether the document requesting the external resource browser data has a defined ModelPath.
Public method Dispose Releases all resources used by the ExternalResourceBrowserData
Public method GetCallingDocumentModelPath Returns a copy of the ModelPath of the document that is requesting the external resource browser data.
Public method GetMatchOptions Gets the match options used to filter external resources.
Public method GetResources Gets the external resources under the folder path of the browser data.
Public method GetSubFoldersData Gets the subfolders data under the folder path of the browser data.
Public method IsValidFolderName Checks whether the folder name is valid.
Public method IsValidResourceName Checks whether the resource name is valid.
Top
Remarks

This data represents the contents to be shown to the user while they are browsing a specific folder in Revit.

The folder path can be obtained from the FolderPath property.

The external resource server is expected to populate all of the available resources and subfolders that should appear in the Revit file browser while the browser is open to this particular folder.

If the user navigates to another folder, a different ExternalResourceBrowserData object will be provided to allow the server to populate resources at that location.

When adding resource and subfolder, the resource and subfolder should not be added recursively.

When adding resource and subfolder, the name should be unique short name(without folder).

The name of resource and subfolder should not contain any invalid character of \/:*?"<>|.

The length of resource combined path(server name + folder path + resource name) should not exceed 259; The length of subfolder also has same restriction.

See Also