FluidTemperatureSetIterator Class


Fluid Temperature Set Iterator Class

An iterator to a set of FluidTemperature from FluidType.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Plumbing FluidTemperatureSetIterator

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FluidTemperatureSetIterator : IEnumerator<FluidTemperature>

The FluidTemperatureSetIterator type exposes the following members.

Properties
Name Description
Public property Current Gets the item at the current position of the iterator.
Protected property CurrentObject
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the FluidTemperatureSetIterator
Public method GetCurrent Returns the current FluidTemperature.
Public method IsDone Identifies if the iteration has completed.
Public method MoveNext Increments the iterator to the next item.
Public method Reset Resets the iterator to the initial state.
Top
See Also