SynchronizeWithCentralOptions Class


Synchronize With Central Options Class

Options to control behavior of synchronization with central.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB SynchronizeWithCentralOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class SynchronizeWithCentralOptions : IDisposable

The SynchronizeWithCentralOptions type exposes the following members.

Constructors
Name Description
Public method SynchronizeWithCentralOptions Constructs a new instance of SynchronizeWithCentralOptions initialized with default options.
Top
Properties
Name Description
Public property Comment User description of changes made since the last Sync with Central. Empty by default.
Public property Compact Indicates whether Revit should compact the central model while synchronizing with central. This option reduces the size of the central model but many increase the time it takes to perform the save. False by default.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property RelinquishBorrowedElements Indicates whether Revit should relinquish borrowed elements after synchronizing with central.
Public property RelinquishFamilyWorksets Indicates whether Revit should relinquish Family worksets after synchronizing with central.
Public property RelinquishProjectStandardWorksets Indicates whether Revit should relinquish Project Standard worksets after synchronizing with central.
Public property RelinquishUserCreatedWorksets Indicates whether Revit should relinquish user-created Standard worksets after synchronizing with central.
Public property RelinquishViewWorksets Indicates whether Revit should relinquish View worksets after synchronizing with central.
Public property SaveLocalAfter True means to save local after saving changes to central. True by default. Silently ignored if the model in the current session is central rather than local.
Public property SaveLocalBefore True means to save local before the first reload latest if there are changes not yet saved to local. True by default. Silently ignored if the model in the current session is central rather than local.
Public property SaveLocalFile Indicates whether Revit will save the local file at least once while synchronizing with central.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the SynchronizeWithCentralOptions
Public method GetRelinquishOptions Gets the options which govern whether or not to relinquish elements and workset types.
Public method SetRelinquishOptions Sets the options which govern whether or not to relinquish elements and workset types.
Top
See Also