GetSpliceGeometries Method


Rebar Splice Utils Get Splice Geometries Method

Computes a list of RebarSpliceGeometry which respects the rules. This list can be used to splice the Rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static RebarSpliceByRulesResult GetSpliceGeometries(
	Document document,
	ElementId rebarIdToSplit,
	RebarSpliceOptions spliceOptions,
	RebarSpliceRules spliceRules
)

Parameters

document Document
The document
rebarIdToSplit ElementId
Rebar id to split.
spliceOptions RebarSpliceOptions
The rebar splice options.
spliceRules RebarSpliceRules
The splice rules.

Return Value

RebarSpliceByRulesResult
Returns the result of the operation. If the operation was successful the RebarSpliceByRulesResult.Error member will have "RebarSpliceByRulesError.Success" value.
Exceptions
Exception Condition
ArgumentException RebarSplicePosition should be Middle.
ArgumentNullException A non-optional argument was null
See Also