GetDistanceToTargetHostFace Method


Rebar Constraint Get Distance To Target Host Face Method

Returns the distance from the RebarConstrainedHandle to the target Host Element surface. The RebarConstraintType of the RebarConstraint must be 'FixedDistanceToHostFace'.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public double GetDistanceToTargetHostFace()

Return Value

Double
Exceptions
Exception Condition
InvalidOperationException RebarConstraint is no longer valid. -or- The RebarConstraint is not of RebarConstraintType 'FixedDistanceToHostFace'.
See Also