ExternalResourceServerExtensions Class


External Resource Server Extensions Class

An object that contains overrides for external resource-specific methods.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ExternalResourceServerExtensions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ExternalResourceServerExtensions : IDisposable

The ExternalResourceServerExtensions type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the ExternalResourceServerExtensions
Public method GetCADLinkOperations Gets the specific methods supported by external resource CAD Links.
Public method GetRevitLinkOperations Gets the specific methods supported by the external resource of Revit Links.
Top
Remarks

This class permits assignment of some specific operations related to a type of external resource, such as what to do when "Open (and Unload)" happens, or when "Shared Coordinates update" happens for Revit or CAD links.

There is no feedback to the UI server for ExternalResourceServerExtensions. Revit will use standard, common message dialogs to handle any error conditions.

See Also