Parameter |
Note: This API is now obsolete.
Creates a filter rule that determines whether strings from the document end with a certain string value.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

[ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")]
public static FilterRule CreateEndsWithRule(
ElementId parameter,
string value,
bool caseSensitive
)
Parameters
- parameter ElementId
- A string-typed parameter used to get values from the document for a given element.
- value String
- The user-supplied string value for which values from the document will be searched.
- caseSensitive Boolean
- If true, the string comparison will be case-sensitive.
Return Value
FilterRule
Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |