InsertVertex Method


Wire Insert Vertex Method

Inserts a new vertex before the specified index.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void InsertVertex(
	int index,
	XYZ vertexPoint
)

Parameters

index Int32
The index of the vertex to come after this new vertex. Should be between 0 and NumberOfVertices .
vertexPoint XYZ
The point of the new vertex.
Exceptions
Exception Condition
ArgumentException The index should be between 0 and the number of vertices of the wire. -or- The vertex point cannot be added to the wire because there is already a vertex at this position on the view plane (within tolerance).
ArgumentNullException A non-optional argument was null
InvalidOperationException Can't insert the vertex before the start vertex if the start point connects to one element.
Remarks
To add a new vertex to the end of the wire, use AppendVertex(XYZ) .
See Also