File |
Base class supporting display of the dialog used to navigate to and select a file from Autodesk Revit.

System Object
Autodesk.Revit.UI FileDialog
Autodesk.Revit.UI FileOpenDialog
Autodesk.Revit.UI FileSaveDialog
Autodesk.Revit.UI FileDialog
Autodesk.Revit.UI FileOpenDialog
Autodesk.Revit.UI FileSaveDialog
Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)

The FileDialog type exposes the following members.

Name | Description | |
---|---|---|
![]() | DefaultFilterEntry | The default entry (from the filter) to be selected in the dialog. |
![]() | Filter | The filter string representing a collection of extensions allowed by the dialog. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | Title | The title to show on the dialog. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the FileDialog |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetSelectedModelPath | Returns the selected file path chosen by the user. |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() ![]() | IsValidFilterString | Determines if the input string is acceptable as input for a FileDialog filter string. |
![]() | Show | Shows the dialog using the stored settings. |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |