Rebar |
Constructs a new instance of a RebarConstraintProjectEdgedLength object using a shape parameter, direction, and reference types.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public RebarShapeConstraintProjectedSegmentLength(
ElementId paramId,
UV direction,
int tripleProductSign,
RebarShapeSegmentEndReferenceType refType0,
RebarShapeSegmentEndReferenceType refType1
)
Parameters
- paramId ElementId
- The Id of a Rebar Shape parameter.
- direction UV
- A vector specifying the direction of the constraint. The direction is fixed, and the shape is always constructed so that the segment's direction has a positive dot product with this vector.
- tripleProductSign Int32
- Sign of the z-coordinate of the cross product of the "direction" argument with the segment vector. In other words, 1 if the segment direction is to be on the left of the constraint direction, or -1 if the segment direction is to be on the right.
- refType0 RebarShapeSegmentEndReferenceType
- Choose between two possibilities for the first reference of the length constraint.
- refType1 RebarShapeSegmentEndReferenceType
- Choose between two possibilities for the second reference of the length constraint.

Exception | Condition |
---|---|
ArgumentException | paramId is not a valid Element identifier. -or- tripleProductSign is not 1 or -1. |
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | direction has zero length. -or- A value passed for an enumeration argument is not a member of that enumeration |