TextNode Class


Text Node Class

This class represents a text annotation object in a model-exporting process.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class TextNode : RenderNode

The TextNode type exposes the following members.

Properties
Name Description
Public property BaseDirection Direction of the base line of the text object in model space.
Public property Color The color of the text.
Public property FontHeight Height [ft] of the text font, in model space.
Public property FontName The name of the text font.
Public property Height Height [ft] of the area of the text content in model space.
Public property HorizontalAlignment Indicates default horizontal alignment of the text.
Public property IsBold Indicates whether the default formatting is set to bold text.
Public property IsItalic Indicates whether the default formatting is set to italic text.
Public property IsKeptReadable Indicates text behavior inside a rotated text object.
Public property IsTransparent Indicates whether the text background is transparent or opaque.
Public property IsUnderlined Indicates whether the default formatting is set to underlined text.
Public property Position Position of the text in model coordinates.
Public property TabSize The size [ft] of the interval between tab stops, in model space.
Public property Text The content of the text annotation as a plain string stripped of all formatting.
Public property UpDirection Direction along the vertical axis of letters of the text object in model space.
Public property VerticalAlignment Indicates default vertical alignment of the text.
Public property Width Width [ft] of the area of the text content in model space.
Public property WidthScale Scale applied to the width of the text.
Top
Methods
Name Description
Public method GetFormattedText Returns an FormattedText object that contains text and associated formatting of this TextNode.
Top
Remarks
See also: OnText(TextNode) .
See Also