Direct |
Sets the family name for the DirectShapeType.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- name String
- Family name for the DirectShapeType.

Exception | Condition |
---|---|
ArgumentException | The element type name was empty, contained invalid characters, or was invalid for the specific element type. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | The given DirectShapeType has a category which does not support a custom family name. |

By default the family name is either Direct Shape or a category-specific name. When a category-specific name is used the family name cannot be set.