CentralModelVersionArchivedException Class


Central Model Version Archived Exception Class

Exception is thrown when last central version merged into the local model has been archived in the central model. Reload Latest or Synchronized with Central needs to be conducted before the current failed operation is retried.
Inheritance Hierarchy

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
[SerializableAttribute]
public class CentralModelVersionArchivedException : CentralModelException

The CentralModelVersionArchivedException type exposes the following members.

Properties
Name Description
Public property Data Gets a collection of key/value pairs that provide additional user-defined information about the exception.
(Inherited from Exception )
Public property FunctionId The information of the function throwing the exception.
(Inherited from ApplicationException )
Public property HelpLink Gets or sets a link to the help file associated with this exception.
(Inherited from Exception )
Public property HResult Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.
(Inherited from Exception )
Public property InnerException Gets the Exception instance that caused the current exception.
(Inherited from Exception )
Public property Message Gets a message that describes the current exception.
(Inherited from Exception )
Public property Source Gets or sets the name of the application or the object that causes the error.
(Inherited from Exception )
Public property StackTrace Gets a string representation of the immediate frames on the call stack.
(Inherited from Exception )
Public property TargetSite Gets the method that throws the current exception.
(Inherited from Exception )
Top
Methods
Name Description
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetBaseException When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
(Inherited from Exception )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetObjectData Retrieves data needed to serialize the target object.
(Overrides CentralModelException GetObjectData(SerializationInfo, StreamingContext) )
Public method GetType Gets the runtime type of the current instance.
(Inherited from Exception )
Public method ToString Creates and returns a string representation of the current exception.
(Inherited from Exception )
Top
Example
void HandleCentralModelVersionArchivedException(Document doc)
{
   FilteredElementCollector collector = new FilteredElementCollector(doc);
   ICollection<ElementId> rooms = collector.WherePasses(new RoomFilter()).ToElementIds();

   try
   {
      ICollection<ElementId> checkoutelements = WorksharingUtils.CheckoutElements(doc, rooms);
   }
   catch (Autodesk.Revit.Exceptions.CentralModelVersionArchivedException)
   {
      TaskDialog dlg = new TaskDialog("Elements can't be checked out")
      {
         MainInstruction = "The local model is out of date. Editing is limited to elements and worksets you own.",
         MainContent = "To check out elements and worksets owned by others, first reload latest or synchronize with the central model.",
      };
      dlg.Show();

      // Reload Latest, to update the local model to latest version
      ReloadLatestOptions rlOptions = new ReloadLatestOptions();
      doc.ReloadLatest(rlOptions);

      rooms = collector.WherePasses(new RoomFilter()).ToElementIds();
      ICollection<ElementId> checkoutelements = WorksharingUtils.CheckoutElements(doc, rooms);

      TaskDialog.Show(
         title: "Elements are checked out",
         mainInstruction: $"{checkoutelements.Count} elements are checked out.");
   }
}
See Also