Schedule |
Type of schedule filter.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)


Member name | Value | Description |
---|---|---|
Invalid | 0 | An invalid filter. Do not use. |
HasParameter | 1 | The element has the parameter specified by the field. Used with shared parameters. No value is specified for this filter type. |
Equal | 2 | The field value is equal to the specified value. |
NotEqual | 3 | The field value is not equal to the specified value. |
GreaterThan | 4 | The field value is greater than the specified value. |
GreaterThanOrEqual | 5 | The field value is greater than or equal to the specified value. |
LessThan | 6 | Less The field value is less than to the specified value. |
LessThanOrEqual | 7 | The field value is less than or equal to the specified value. |
Contains | 8 | For a string field, the field value contains the specified string. |
NotContains | 9 | For a string field, the field value does not contain the specified string. |
BeginsWith | 10 | For a string field, the field value begins with the specified string. |
NotBeginsWith | 11 | For a string field, the field value does not begin with the specified string. |
EndsWith | 12 | For a string field, the field value ends with specified string. |
NotEndsWith | 13 | For a string field, the field value does not end with the specified string. |
IsAssociatedWithGlobalParameter | 14 | The field is associated with a specified global parameter of a compatible type |
IsNotAssociatedWithGlobalParameter | 15 | The field is not associated with a specified global parameter of a compatible type |
HasValue | 16 | The element has a value for the specified parameter. No value is specified. |
HasNoValue | 17 | The element does not have a value for the specified parameter. No value is specified. |