Wave Class


Wave Class

A static class that provides access to the property names that appear in the Wave visual asset schema.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Visual Wave

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class Wave

The Wave type exposes the following members.

Properties
Name Description
Public property Static member TextureAngle The property labeled "Angle" from the "Wave" schema.
Public property Static member TextureLinkTextureTransforms The property labeled "Link Transforms" from the "Wave" schema.
Public property Static member TextureRealWorldOffsetX The property labeled "Offset X" from the "Wave" schema.
Public property Static member TextureRealWorldOffsetY The property labeled "Offset Y" from the "Wave" schema.
Public property Static member TextureRealWorldOffsetZ The property labeled "Offset Z" from the "Wave" schema.
Public property Static member WaveAmplitude The property labeled "Amplitude" from the "Wave" schema.
Public property Static member WaveColor1 The property labeled "Color 1" from the "Wave" schema.
Public property Static member WaveColor2 The property labeled "Color 2" from the "Wave" schema.
Public property Static member WaveDistribution The property labeled "Distribution" from the "Wave" schema.
Public property Static member WaveNumWaveSets The property labeled "Number" from the "Wave" schema.
Public property Static member WavePhase The property labeled "Phase" from the "Wave" schema.
Public property Static member WaveRandomSeed The property labeled "Random Seed" from the "Wave" schema.
Public property Static member WaveWaveLenMax The property labeled "Len Max" from the "Wave" schema.
Public property Static member WaveWaveLenMin The property labeled "Len Min" from the "Wave" schema.
Public property Static member WaveWaveRadius The property labeled "Radius" from the "Wave" schema.
Top
See Also