Cable |
Creates a new instance of cable tray.
Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static CableTray Create(
Document document,
ElementId cabletrayType,
XYZ startPoint,
XYZ endPoint,
ElementId levelId
)
Parameters
- document Document
- The document.
- cabletrayType ElementId
- The cable tray type. This must be a cable tray type accepted by isValidCableTrayType(). If the input cable tray type is InvalidElementId, the default cable tray type from the document will be used.
- startPoint XYZ
- The start point of the cable tray location line.
- endPoint XYZ
- The end point of the cable tray location line.
- levelId ElementId
- The element id of the level which this cable tray based. If the input level id is invalidElementId = -1, the nearest level will be used.
Return Value
CableTrayThe newly created cable tray.

Exception | Condition |
---|---|
ArgumentException | This cable tray type is invalid. -or- This level id is invalid. -or- The points of startPoint and endPoint are too close: for MEPCurve, the minimum length is 1/10 inch. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). |
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
ModificationOutsideTransactionException | The document has no open transaction. |

This method will regenerate the document.