ElementClassFilter Constructor (Type, Boolean)


Element Class Filter(Type, Boolean) Constructor

Constructs a new instance of a filter to match elements by class, with the option to match all elements which are not of the given class.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementClassFilter(
	Type type,
	bool inverted
)

Parameters

type Type
The type to match.
inverted Boolean
True if the filter should match all elements which are not of the given class.
Exceptions
Exception Condition
ArgumentException The input type is not a subclass of Element. -or- The input type is of an element class that exists in the API, but not in Revit's native object model.
ArgumentNullException A non-optional argument was null
See Also