TriOrQuadFacet Class


Tri Or Quad Facet Class

This class represents a triangle or quadrilateral in a faceted structure.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB TriOrQuadFacet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class TriOrQuadFacet : IDisposable

The TriOrQuadFacet type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Normal A unit normal vector for this facet.
Public property NumberOfVertices The number of vertices (3 for a triangle, 4 for a quadrilateral, 0 for an unset TriOrQuadFacet).
Top
Methods
Name Description
Public method Dispose Releases all resources used by the TriOrQuadFacet
Public method GetVertexIndex Returns the index of the specified vertex of this facet (as an index into the external array of vertices in the TriangulationInterface that was used to create the list of TriOrQuadFacets).
Top
Remarks
This class defines a triangle or quadrilateral with reference to an external triangulation structure. The vertices of this TriOrQuadFacet are indices into the triangulation structure's array of vertices.
See Also