ConvertToStableRepresentation Method


Reference Convert To Stable Representation Method

Converts the reference to a stable String representation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public string ConvertToStableRepresentation(
	Document document
)

Parameters

document Document
The document.

Return Value

String
Exceptions
Exception Condition
ArgumentNullException document was .
InvalidObjectException Reference contained element ids not found in this document.
Remarks
The stable representation can be used to preserve and restore the reference later in the same Revit session or even in a different session where the same document is present. Use ParseFromStableRepresentation(Document, String) to restore the reference. The representation is based on the internal Revit structure and is not intended to be parsed expect by ParseFromStableRepresentation(Document, String) .
Example
public string SerializeReference(Document doc, Reference reference)
{
    String ids = String.Empty;
    ids = reference.ConvertToStableRepresentation(doc);
    TaskDialog.Show("SerializeReference", "Representation:\n" + ids);
    return ids;
}
See Also