FamilyThermalProperties Class


Family Thermal Properties Class

A class that contains thermal properties for specific types of families (doors, windows, and curtain wall panels).
Inheritance Hierarchy
System Object
Autodesk.Revit.DB FamilyThermalProperties

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FamilyThermalProperties : IDisposable

The FamilyThermalProperties type exposes the following members.

Constructors
Name Description
Public method FamilyThermalProperties Constructs a new FamilyThermalProperties with default settings.
Top
Properties
Name Description
Public property AnalyticConstructionName The construction gbXML name. This value corresponds to the 'Name' property of a constructionType node in Constructions.xml.
Public property AnalyticConstructionTypeId The construction gbXML type. This value corresponds to the 'id' property of a constructionType node in Constructions.xml.
Public property HeatTransferCoefficient The heat transfer coefficient value (U-Value). The units are watts per meter-squared kelvin (W/(m^2*K)).
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property SolarHeatGainCoefficient The solar heat gain coefficient.
Public property ThermalResistance The calculated thermal resistance value (R-Value). The units are meter-squared kelvin per watt ((m^2*K)/Watt).
Public property VisualLightTransmittance The visual light transmittance.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the FamilyThermalProperties
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method Static member Find Finds the thermal properties by the 'id' property of a constructionType node in Constructions.xml.
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method IsValid Confirms that the thermal properties are correctly set for assignment to a FamilySymbol.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also