Invalid |
The exception that is thrown when a method call is invalid for the object's current state.

System Object
System Exception
Autodesk.Revit.Exceptions ApplicationException
Autodesk.Revit.Exceptions InvalidOperationException
More
System Exception
Autodesk.Revit.Exceptions ApplicationException
Autodesk.Revit.Exceptions InvalidOperationException
More
Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The InvalidOperationException type exposes the following members.

Name | Description | |
---|---|---|

Name | Description | |
---|---|---|
![]() | GetObjectData | Retrieves data needed to serialize the target object. (Overrides ApplicationException GetObjectData(SerializationInfo, StreamingContext) ) |

Reference

System Object
System Exception
Autodesk.Revit.Exceptions ApplicationException
Autodesk.Revit.Exceptions InvalidOperationException
Autodesk.Revit.Exceptions AutoJoinFailedException
Autodesk.Revit.Exceptions CannotOpenBothCentralAndLocalException
Autodesk.Revit.Exceptions DefaultValueException
Autodesk.Revit.Exceptions DisabledDisciplineException
Autodesk.Revit.Exceptions FamilyContextException
Autodesk.Revit.Exceptions ForbiddenForDynamicUpdateException
Autodesk.Revit.Exceptions InapplicableDataException
Autodesk.Revit.Exceptions InsufficientResourcesException
Autodesk.Revit.Exceptions InvalidObjectException
Autodesk.Revit.Exceptions ModificationForbiddenException
Autodesk.Revit.Exceptions ModificationOutsideTransactionException
Autodesk.Revit.Exceptions NotTransmittedModelException
Autodesk.Revit.Exceptions ObjectAccessException
Autodesk.Revit.Exceptions OptionalFunctionalityNotAvailableException
Autodesk.Revit.Exceptions RegenerationFailedException
Autodesk.Revit.Exceptions SchemaException
Autodesk.Revit.Exceptions TransientElementCreationException
Autodesk.Revit.Exceptions TransmittedModelException
Autodesk.Revit.Exceptions WrongUserException
System Exception
Autodesk.Revit.Exceptions ApplicationException
Autodesk.Revit.Exceptions InvalidOperationException
Autodesk.Revit.Exceptions AutoJoinFailedException
Autodesk.Revit.Exceptions CannotOpenBothCentralAndLocalException
Autodesk.Revit.Exceptions DefaultValueException
Autodesk.Revit.Exceptions DisabledDisciplineException
Autodesk.Revit.Exceptions FamilyContextException
Autodesk.Revit.Exceptions ForbiddenForDynamicUpdateException
Autodesk.Revit.Exceptions InapplicableDataException
Autodesk.Revit.Exceptions InsufficientResourcesException
Autodesk.Revit.Exceptions InvalidObjectException
Autodesk.Revit.Exceptions ModificationForbiddenException
Autodesk.Revit.Exceptions ModificationOutsideTransactionException
Autodesk.Revit.Exceptions NotTransmittedModelException
Autodesk.Revit.Exceptions ObjectAccessException
Autodesk.Revit.Exceptions OptionalFunctionalityNotAvailableException
Autodesk.Revit.Exceptions RegenerationFailedException
Autodesk.Revit.Exceptions SchemaException
Autodesk.Revit.Exceptions TransientElementCreationException
Autodesk.Revit.Exceptions TransmittedModelException
Autodesk.Revit.Exceptions WrongUserException