ConnectDuctPlaceholdersAtTee Method (Document, ElementId, ElementId)


Mechanical Utils Connect Duct Placeholders At Tee(Document, Element Id, Element Id) Method

Connects a pair of placeholders that can intersect in a Tee connection.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool ConnectDuctPlaceholdersAtTee(
	Document document,
	ElementId placeholder1Id,
	ElementId placeholder2Id
)

Parameters

document Document
The document.
placeholder1Id ElementId
The element Id of the first duct placeholder.
placeholder2Id ElementId
The element Id of the second duct placeholder.

Return Value

Boolean
True if connection succeeds, false otherwise.
Exceptions
Exception Condition
ArgumentException The element id placeholder1Id is not duct placeholder. -or- The element id placeholder2Id is not duct placeholder. -or- The elements belong to different types of system. -or- The curve placeholder2Id does not connect on the curve placeholder1Id or vice versa.
ArgumentNullException A non-optional argument was null
Remarks
The placeholders must have a physical intersection. If connection fails, the placeholders cannot be physically connected.
See Also