Boundary |
The Id of the internal load element associated with a boundary conditions.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)


Exception | Condition |
---|---|
ArgumentException | When setting this property: elementId is not a valid Element identifier. -or- When setting this property: Throws when the ElementId does not refer to the internal load with appropriate type. |
ArgumentNullException | When setting this property: A non-optional argument was null |

ElementId may be set if the internal load exists and it's type fit the BoundaryConditions type only (Point, Line and Area).