Logical |
A filter that contains a set of filters. The filter passes when any filter in the set passes.

System Object
Autodesk.Revit.DB ElementFilter
Autodesk.Revit.DB ElementLogicalFilter
Autodesk.Revit.DB LogicalOrFilter
Autodesk.Revit.DB ElementFilter
Autodesk.Revit.DB ElementLogicalFilter
Autodesk.Revit.DB LogicalOrFilter
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The LogicalOrFilter type exposes the following members.

Name | Description | |
---|---|---|
![]() | LogicalOrFilter(IList ElementFilter ) | Constructs a new instance of the logical filter with any number of input filters. |
![]() | LogicalOrFilter(ElementFilter, ElementFilter) | Constructs a new instance of the logical filter with two input filters. |

Name | Description | |
---|---|---|

Name | Description | |
---|---|---|

The component filters may be reordered by Revit to cause the quickest acting filters to be evaluated first.