CreateStyle Method (ExporterIFC, IFCAnyHandle)


IFCFile Create Style(Exporter IFC, IFCAny Handle) Method

Creates and populates an IfcStyledItem for an IfcRepresentationItem with a IfcSurfaceStyle, IfcCurveStyle, and/or an IfcFillStyle, and assigns them to the file.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public IFCAnyHandle CreateStyle(
	ExporterIFC exporterIFC,
	IFCAnyHandle repItem
)

Parameters

exporterIFC ExporterIFC
The exporter.
repItem IFCAnyHandle
The representation item.

Return Value

IFCAnyHandle
The handle.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
InvalidOperationException A transaction is required for this operation.
See Also