AssignedPressureDrop Property


Connector Assigned Pressure Drop Property

The assigned pressure drop of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public double AssignedPressureDrop { get; set; }

Property Value

Double
Exceptions
Exception Condition
InvalidOperationException Thrown when the connector is not in a family instance. Thrown when the connector's domain is not DomainHvac or DomainPiping.
ArgumentException Thrown when set an invalid value.
InvalidOperationException Thrown on failure to get or set assigned pressure drop.
Remarks
Assigned pressure drop may be assigned for connectors of some family instances. In order to set this property, it must be mapped to a writable instance parameter in the family definition.
See Also