RebarContainerParameterManager Class


Rebar Container Parameter Manager Class

Provides implementation of RebarContainer parameters overrides.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure RebarContainerParameterManager

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RebarContainerParameterManager : IDisposable

The RebarContainerParameterManager type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method AddOverride(ElementId, ElementId) Adds an override for the given parameter as its value will be displayed for the Rebar Container element.
Public method Code example AddOverride(ElementId, Double) Adds an override for the given parameter as its value will be displayed for the Rebar Container element.
Public method AddOverride(ElementId, Int32) Adds an override for the given parameter as its value will be displayed for the Rebar Container element.
Public method AddOverride(ElementId, String) Adds an override for the given parameter as its value will be displayed for the Rebar Container element.
Public method Code example AddSharedParameterAsOverride Adds a shared parameter as one of the parameter overrides stored by this Rebar Container element.
Public method ClearOverrides Clears any overridden values from all parameters of the associated RebarContainer element.
Public method Dispose Releases all resources used by the RebarContainerParameterManager
Public method GetDoubleOverrideValue Get the double value for an overriden parameter.
Public method GetElementIdOverrideValue Get the ElementId value for an overriden parameter.
Public method GetIntOverrideValue Get the integer value for an overriden parameter.
Public method GetStringOverrideValue Get the string value for an overriden parameter.
Public method IsOverriddenParameterModifiable Checks if overridden parameter is modifiable.
Public method IsParameterOverridden Checks if the parameter has an override
Public method IsRebarContainerParameter Checks if the parameter is a Rebar Container parameter
Public method RemoveOverride Removes an overridden value from the given parameter.
Public method SetOverriddenParameterModifiable Sets this overridden parameter to be modifiable.
Public method SetOverriddenParameterReadonly Sets this overridden parameter to be readonly.
Top
Remarks
When a new override is created, by default, the parameter will show the overridden value as read-only. You can control whether or not the parameter is modifiable using SetOverriddenParameterReadonly(ElementId) and SetOverriddenParameterModifiable(ElementId) .a
See Also