SetCategories Method


Parameter Filter Element Set Categories Method

Sets the categories admitted by this filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetCategories(
	ICollection<ElementId> categories
)

Parameters

categories ICollection ElementId
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks

Testing that an element's category is a member of this set is, essentially, the first rule of the filter.

Changing the set of categories will clear any rules that use parameters that are not applicable for the new set of categories.

See Also