FamilyInstanceCreationData Constructor (Curve, FamilySymbol, Level, StructuralType)


Family Instance Creation Data(Curve, Family Symbol, Level, Structural Type) Constructor

Initializes a new instance of the FamilyInstanceCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public FamilyInstanceCreationData(
	Curve curve,
	FamilySymbol symbol,
	Level level,
	StructuralType structuralType
)

Parameters

curve Curve
The curve where the instance is based.
symbol FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
level Level
A Level object that is used as the base level for the object.
structuralType StructuralType
If structural then specify the type of the component.
See Also