BuiltInFailures.MechanicalFailures Class


Built In Failures Mechanical Failures Class

Failures about HVAC.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BuiltInFailures MechanicalFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class MechanicalFailures

The BuiltInFailures MechanicalFailures type exposes the following members.

Properties
Name Description
Public property Static member InitialEqualFrictionSizingFailed Initial Equal Friction Sizing failed.
Public property Static member LiningThicknessIsLargeForDiameter Lining Thickness ([Lining Thickness Value]) is too large for current Diameter ([Diameter Value]).
Public property Static member LiningThicknessIsLargeForHeight Lining Thickness ([Lining Thickness Value]) is too large for current Height ([Height Value]).
Public property Static member LiningThicknessIsLargeForWidth Lining Thickness ([Lining Thickness Value]) is too large for current Width ([Width Value]).
Public property Static member PanelDoesntMatchCircuitProperties The panel no longer matches the properties for the Circuit. Disconnect the panel from the Circuit?
Public property Static member PanelValidateConfigurationError More than one circuit falls onto the same slot. Disconnect the circuits from the panel?
Public property Static member TwoPointsSelectedBeforeEdit Two points have to be selected before existing the edit mode.
Top
See Also